Intermittent connections to app

Incident Report for Noterro

Postmortem

During a scheduled maintenance window today, a database change that performed well in testing did not perform as expected under production load. This caused connection delays and failures, resulting in pages not loading for some users.

Our team identified the root cause quickly and the issue has been resolved. We are reviewing our testing process to prevent similar incidents.

We apologize for the disruption.

Posted Jun 02, 2026 - 10:34 EDT

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 10:32 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 10:12 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 02, 2026 - 10:08 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2026 - 10:08 EDT
This incident affected: Web App.