Appointment Notifications Not Delivering

Incident Report for Noterro

Resolved

This incident has been resolved.
Posted May 07, 2026 - 13:05 EDT

Investigating

We are currently investigating an issue where some staff users are not receiving notifications of new bookings.
Posted May 06, 2026 - 20:49 EDT
This incident affected: Web App.