Intermittent or Slow Connections

Incident Report for Noterro

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:49 EDT

Identified

Our infrastructure provider, Amazon Web Services, is experiencing a service outage, causing some users to experience slow or intermittent connections and page loads. Amazon Web Services is actively working to resolve this.
Posted Oct 20, 2025 - 12:58 EDT
This incident affected: Web App.